Wireless shifting for the rest of us...

Free FedEx shipping over $200
App crashes when tu...
Clear all

App crashes when tuning cog positions

2 Posts
3 Users
Topic starter

I connected to the system (Quantum and BlakBullet) through the app. Managed to map buttons for shifting up and down and also managed to update firmware on both systems (Quantum and BlakBullet). 

I can move the system with the buttons but the positions stored in the Quantum are inadequate for my derailleur. Therefore I'm trying to tune/adjust the individual cog positions. However, whenever I try tuning the cog positions the app crashes. 

In section "Tune" I can move the Quantum pushing the arrows at the sides of the gear number. However, when willing to adjust the position  of a particular cog by pushing on jog buttons ("+" or "-") the app crashes and closes completely. 

The same happens in section "Manual Setup". After selecting the number of cogs to be adjusted and clicking on "Next", whenever I push the jog buttons ("+" or "-") the app crashes and closes completely. 

I tried this with 3 different phones: Google Pixel 4a with Android 13, Oppo A74 with Android 12 and Moto G10 with Android 11. 

The issue is exactly the same in all cases. Could you please advise how to solve this?

M-L Topic starter 09/03/2023 7:13 pm

I complete this thread with the info I provided in another post in the "Troubleshooting" section:

- Basically the only thing not working is moving the cog positions with jog buttons ("+" and "-"), both in the "Tune" section and in the "Manual Setup" section

- "Motor Homing" is working without any issue when commanded from the app

- Save configuration seems to work in "Tune" section. The issue is I cannot move the system with jog buttons so in "Tune" section I guess I save the same configuration over and over again. What I can do is shift gears with the arrows at both sides of the gear-number. Since the positining accuracy seems to be 0.1 mm, if I shift around the same gear over and over again, occasionally the system gets positioned 0.1 mm away from the original goal position, and then I can store such position. I think if I repeat this procedure multiple times I may end up bringing the system to a desired position. But the procedure would take a tremendous amount of work.

- Save configuration also works on "Manual Setup" section. However in this case I have no other possibility than jog buttins ("+" and "-") to move the system. Therefore, after selecting the number of cogs, my only possibility is to click on "next" when positining the "smallest cog" (or crash the app if I click on the jog buttons). Then I get to the "largest cog" screen: since I cannot vary cog position, the smallest and largest cog positions coincide and if I click "Finish", the system stores positions and I get a Quantum system that does not move since all cogs are located in the same position.

- I can configure BlakBullet buttons without any issue, and I can see indications in the app when these are pressed, and the Quantum can be moved from the buttons without issues.

Also, I tried reseting of the device (red leds blink), homing via button (not via the app) and the start again the setup process and it did not work

List of phones tested:
Google Pixel 4a with Android 13
Oppo A74 with Android 12
Moto G10 with Android 11
Realme 9 Pro with Android 12
Samsung Galaxy A3 with Android 7
Samsung A53 with Android 12 (brand new)
Samsung A53 with Android 13 (brand new, different terminal from previous)

The same exact issue occurred in all cases: the app crashes and closes completely when hitting any of the jog buttons ("+" or "-"), either on "Tune" or on "Manual Setup" section. Everything else seems to work.

The reproducibility of the issue seems to indicate there is a deeper problem, especialy related to the way jog button functions ("+" and "-") are programmed in the app. I'm totally clueless about how to proceed unless NXS delivers an updated version

Hope all this information helps illustrating what is working and what not, so that you can have a more clear picture of the issue and hopefully you can provide a solution

M-L Topic starter 09/03/2023 7:36 pm

Maybe if you (NXS) could indicate which phone model and which Android version you tested satisfactorily, then if I eventually manage to have access to such phone model I can complete the analysis and/or check whether it is actually working without any issue...

Shopping cart
Select your currency
0 items Cart
My account